Follow

WordRake for Mac System Requirements

WordRake for Mac is available on the the following Mac OS versions:

  • El Capitan
  • Sierra
  • High Sierra
  • Mojave

WordRake for Mac requires Microsoft Word 2016 or Word 2019 or Office 365 and works best with version 16.9 or higher.  It is not supported on earlier versions of Microsoft Word.

Have more questions? Submit a request